summaryrefslogtreecommitdiff
path: root/test/c/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2007-10-31 17:09:12 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2007-10-31 17:09:12 +0000
commitfd04963da2f16cf22de5613bb793b0302ea99b70 (patch)
treeca8bd1f4a56b9177c59ca837481d6564a8328ef1 /test/c/Makefile
parent108804d88e16b00f171c2ac546c6c1a60f3c3ff8 (diff)
Problemes d'alignement des variables globales et a l'interieur de leurs initialiseurs
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@444 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/c/Makefile')
-rw-r--r--test/c/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/test/c/Makefile b/test/c/Makefile
index 3f4ea40..3ee10c9 100644
--- a/test/c/Makefile
+++ b/test/c/Makefile
@@ -9,10 +9,12 @@ LIBS=
TIME=xtime -o /dev/null -mintime 1.0 # Xavier's hack
#TIME=time >/dev/null # Otherwise
-PROGS=fib integr qsort fft sha1 aes almabench lists \
+BENCHS=fib integr qsort fft sha1 aes almabench lists \
binarytrees fannkuch knucleotide mandelbrot nbody \
nsieve nsievebits spectral
+PROGS=$(BENCHS) initializers
+
all_s: $(PROGS:%=%.s)
all: $(PROGS:%=%.compcert)
@@ -45,12 +47,12 @@ test_gcc:
done
time_gcc:
- @for i in $(PROGS); do \
+ @for i in $(BENCHS); do \
echo -n "$$i: "; $(TIME) ./$$i.gcc; \
done
time_compcert:
- @for i in $(PROGS); do \
+ @for i in $(BENCHS); do \
echo -n "$$i: "; $(TIME) ./$$i.compcert; \
done