summaryrefslogtreecommitdiff
path: root/runtime
diff options
context:
space:
mode:
Diffstat (limited to 'runtime')
-rw-r--r--runtime/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/runtime/Makefile b/runtime/Makefile
index c45c9fb..9a3f621 100644
--- a/runtime/Makefile
+++ b/runtime/Makefile
@@ -1,7 +1,10 @@
+include ../Makefile.config
+
CFLAGS=-arch ppc -O1 -g -Wall
#CFLAGS=-O1 -g -Wall
OBJS=stdio.o calloc.o
LIB=libcompcert.a
+INCLUDES=stdio.h
$(LIB): $(OBJS)
rm -f $(LIB)
@@ -11,3 +14,7 @@ stdio.o: stdio.h
clean:
rm -f *.o $(LIB)
+
+install:
+ install -d $(LIBDIR)
+ install -c $(LIB) $(INCLUDES) $(LIBDIR)