summaryrefslogtreecommitdiff
path: root/runtime
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2007-08-06 08:45:25 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2007-08-06 08:45:25 +0000
commit94aea0609bb54f0fde29a558366b646b3b8d21a2 (patch)
tree2c81bb38c04b6ca50dd8588681fe68baa71a237a /runtime
parentc0bc146622528e3d52534909f5ae5cd2e375da8f (diff)
Ajout et utilisation de caml/Driver.ml. Ajout ./configure. Revu Makefiles
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@387 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'runtime')
-rw-r--r--runtime/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/runtime/Makefile b/runtime/Makefile
index c45c9fb..9a3f621 100644
--- a/runtime/Makefile
+++ b/runtime/Makefile
@@ -1,7 +1,10 @@
+include ../Makefile.config
+
CFLAGS=-arch ppc -O1 -g -Wall
#CFLAGS=-O1 -g -Wall
OBJS=stdio.o calloc.o
LIB=libcompcert.a
+INCLUDES=stdio.h
$(LIB): $(OBJS)
rm -f $(LIB)
@@ -11,3 +14,7 @@ stdio.o: stdio.h
clean:
rm -f *.o $(LIB)
+
+install:
+ install -d $(LIBDIR)
+ install -c $(LIB) $(INCLUDES) $(LIBDIR)