summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 54c0cf4..5d572eb 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,7 @@ COQC=coqc -q $(INCLUDES)
COQDEP=coqdep $(INCLUDES)
COQDOC=coqdoc
COQEXEC=coqtop $(INCLUDES) -batch -load-vernac-source
+COQCHK=coqchk $(INCLUDES)
OCAMLBUILD=ocamlbuild
OCB_OPTIONS=\
@@ -186,6 +187,12 @@ distclean:
check-admitted: $(FILES)
@grep -w 'admit\|Admitted\|ADMITTED' $^ || echo "Nothing admitted."
+# Problems with coqchk:
+# Integers.one_bits_range takes forever to check
+# Mach#<>#instruction causes a failure
+check-proof: $(FILES)
+ $(COQCHK) -admit Integers Complements
+
include .depend
FORCE: