summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-08-22 09:41:12 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-08-22 09:41:12 +0000
commit97a1231b8f3de4d413fc3347f941812860616575 (patch)
tree62c32ce3b2120d8314ab81c77e09e94545ea3912 /Makefile
parent6ceceaed3d71a785fa1cccc1059c9a141e99eee1 (diff)
Changelog, doc: updated for release 1.9
lib/Integers, Makefile: unsuccessful experiments with coqchk git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1723 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 54c0cf4..5d572eb 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,7 @@ COQC=coqc -q $(INCLUDES)
COQDEP=coqdep $(INCLUDES)
COQDOC=coqdoc
COQEXEC=coqtop $(INCLUDES) -batch -load-vernac-source
+COQCHK=coqchk $(INCLUDES)
OCAMLBUILD=ocamlbuild
OCB_OPTIONS=\
@@ -186,6 +187,12 @@ distclean:
check-admitted: $(FILES)
@grep -w 'admit\|Admitted\|ADMITTED' $^ || echo "Nothing admitted."
+# Problems with coqchk:
+# Integers.one_bits_range takes forever to check
+# Mach#<>#instruction causes a failure
+check-proof: $(FILES)
+ $(COQCHK) -admit Integers Complements
+
include .depend
FORCE: