summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7357e5e..70f6013 100644
--- a/Makefile
+++ b/Makefile
@@ -122,7 +122,9 @@ all:
$(MAKE) proof
$(MAKE) extraction
$(MAKE) ccomp
+ifeq ($(HAS_RUNTIME_LIB),true)
$(MAKE) runtime
+endif
ifeq ($(CCHECKLINK),true)
$(MAKE) cchecklink
endif
@@ -225,7 +227,9 @@ install:
ifeq ($(CCHECKLINK),true)
install ./cchecklink $(BINDIR)
endif
+ifeq ($(HAS_RUNTIME_LIB),true)
$(MAKE) -C runtime install
+endif
clean:
rm -f $(patsubst %, %/*.vo, $(DIRS))