summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-05-29 13:09:51 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-05-29 13:09:51 +0000
commit7c9b3828ab1d29ef50cb2c7756eadfb190804476 (patch)
tree688338a8648b4266711a90f11ee4e468b68f39a0 /Makefile
parent85c3c92d4ea73393ee67da8f3b811d221b4e06f5 (diff)
Fix compilation of runtime system.
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2263 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7357e5e..70f6013 100644
--- a/Makefile
+++ b/Makefile
@@ -122,7 +122,9 @@ all:
$(MAKE) proof
$(MAKE) extraction
$(MAKE) ccomp
+ifeq ($(HAS_RUNTIME_LIB),true)
$(MAKE) runtime
+endif
ifeq ($(CCHECKLINK),true)
$(MAKE) cchecklink
endif
@@ -225,7 +227,9 @@ install:
ifeq ($(CCHECKLINK),true)
install ./cchecklink $(BINDIR)
endif
+ifeq ($(HAS_RUNTIME_LIB),true)
$(MAKE) -C runtime install
+endif
clean:
rm -f $(patsubst %, %/*.vo, $(DIRS))