summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-10-16 09:50:38 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-10-16 09:50:38 +0000
commitc857f0b02463f4b0bc8100434eecdd46ce2ecbd1 (patch)
tree4496e88a95bac87525f6422274a8b5dafc4c356b /test
parent32b9fdc4332a6af5d108a0468399661867f4d2b4 (diff)
Cminor parsing and printing (from Andrew Tolmach)
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2345 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test')
-rw-r--r--test/c/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/c/Makefile b/test/c/Makefile
index 1444073..1486666 100644
--- a/test/c/Makefile
+++ b/test/c/Makefile
@@ -56,6 +56,17 @@ bench:
echo -n "$$i: "; $(TIME) ./$$i.compcert; \
done
+cminor_roundtrip:
+ @for i in $(PROGS); do \
+ $(CCOMP) -dcminor -S $$i.c; \
+ cp $$i.cm $$i.1.cm; \
+ $(CCOMP) -dcminor -S $$i.cm; \
+ if cmp -s $$i.1.cm $$i.cm; \
+ then echo "$$i: round trip passed"; rm -f $$i.1.cm $$i.cm; \
+ else echo "$$i: round trip FAILED"; diff -u $$i.1.cm $$i.cm; \
+ fi; \
+ done
+
clean:
rm -f *.compcert *.gcc
- rm -f *.light.c *.parsed.c *.s *.o *~
+ rm -f *.compcert.c *.light.c *.parsed.c *.s *.o *~