summaryrefslogtreecommitdiff
path: root/test/c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/c/Makefile')
-rw-r--r--test/c/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/c/Makefile b/test/c/Makefile
index 1444073..1486666 100644
--- a/test/c/Makefile
+++ b/test/c/Makefile
@@ -56,6 +56,17 @@ bench:
echo -n "$$i: "; $(TIME) ./$$i.compcert; \
done
+cminor_roundtrip:
+ @for i in $(PROGS); do \
+ $(CCOMP) -dcminor -S $$i.c; \
+ cp $$i.cm $$i.1.cm; \
+ $(CCOMP) -dcminor -S $$i.cm; \
+ if cmp -s $$i.1.cm $$i.cm; \
+ then echo "$$i: round trip passed"; rm -f $$i.1.cm $$i.cm; \
+ else echo "$$i: round trip FAILED"; diff -u $$i.1.cm $$i.cm; \
+ fi; \
+ done
+
clean:
rm -f *.compcert *.gcc
- rm -f *.light.c *.parsed.c *.s *.o *~
+ rm -f *.compcert.c *.light.c *.parsed.c *.s *.o *~