summaryrefslogtreecommitdiff
path: root/test/regression
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-02-02 11:32:47 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-02-02 11:32:47 +0000
commit8f2e818c444363e29675d569ceaac48203f9d006 (patch)
tree290e1b86688466b686dad14d644c3d57839c5ba9 /test/regression
parentd2cf6277ac179c9e8432d4c11a79e9f906a19bbc (diff)
Errors for excessively large global variables or stack frames.
test/: update Makefiles so that "all" is the default target. git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2107 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/regression')
-rw-r--r--test/regression/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/regression/Makefile b/test/regression/Makefile
index 0a9212d..31ea51b 100644
--- a/test/regression/Makefile
+++ b/test/regression/Makefile
@@ -22,10 +22,10 @@ EXTRAS=annot1 commaprec expr2 expr3 expr4 extern1 funct2 funptr1 init1 \
# Test known to fail
FAILURES=funct1 varargs1
-all_s: $(TESTS:%=%.s) $(EXTRAS:%=%.s)
-
all: $(TESTS:%=%.compcert) $(EXTRAS:%=%.s)
+all_s: $(TESTS:%=%.s) $(EXTRAS:%=%.s)
+
%.compcert: %.c $(CCOMP)
$(CCOMP) $(CCOMPFLAGS) -o $*.compcert $*.c $(LIBS)