summaryrefslogtreecommitdiff
path: root/test/regression/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/regression/Makefile')
-rw-r--r--test/regression/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/regression/Makefile b/test/regression/Makefile
index 0a9212d..31ea51b 100644
--- a/test/regression/Makefile
+++ b/test/regression/Makefile
@@ -22,10 +22,10 @@ EXTRAS=annot1 commaprec expr2 expr3 expr4 extern1 funct2 funptr1 init1 \
# Test known to fail
FAILURES=funct1 varargs1
-all_s: $(TESTS:%=%.s) $(EXTRAS:%=%.s)
-
all: $(TESTS:%=%.compcert) $(EXTRAS:%=%.s)
+all_s: $(TESTS:%=%.s) $(EXTRAS:%=%.s)
+
%.compcert: %.c $(CCOMP)
$(CCOMP) $(CCOMPFLAGS) -o $*.compcert $*.c $(LIBS)