summaryrefslogtreecommitdiff
path: root/runtime
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-04-20 11:54:06 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-04-20 11:54:06 +0000
commit9b00b13ed8c4efc78f8644bae71c375087033f17 (patch)
treede0d4358133a5d96bafa6a01845c6feadd909cdb /runtime
parent1aa06c816cc48767db0546b1671f7a3c2a55d4c5 (diff)
Configuring the assembler used for the runtime lib
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2205 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'runtime')
-rw-r--r--runtime/Makefile2
-rw-r--r--runtime/arm/int64.s2
2 files changed, 3 insertions, 1 deletions
diff --git a/runtime/Makefile b/runtime/Makefile
index 5550e6b..5ed24af 100644
--- a/runtime/Makefile
+++ b/runtime/Makefile
@@ -12,7 +12,7 @@ $(LIB): $(OBJS)
ar rcs $(LIB) $(OBJS)
%.o: $(ARCH)/%.s
- $(CASM) $^
+ $(CASMRUNTIME) $^
clean::
rm -f *.o $(LIB)
diff --git a/runtime/arm/int64.s b/runtime/arm/int64.s
index 58ac024..5f01679 100644
--- a/runtime/arm/int64.s
+++ b/runtime/arm/int64.s
@@ -201,6 +201,8 @@ __i64_umod:
.type __i64_umod, %function
.size __i64_umod, . - __i64_umod
+@@@ Signed division
+
.global __i64_sdiv
__i64_sdiv:
push {r4, r5, r6, r7, r8, r10, lr}