summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-07-23 13:14:02 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-07-23 13:14:02 +0000
commit783288d052bbcf75e250dff5018443d109c6101c (patch)
treec7254dde41f1bb1229cad9f49a0bfd4482293aba /Makefile
parentae6f7b8d4cf30fbc2f56c3f2baa8f028fb7f9c10 (diff)
Merge the various $(ARCH)/$(VARIANT)/xxx.v files into $(ARCH)/xxx.v.
The only platform where we have two variants is ARM, and it's easier to share the callling convention code between the two than to maintain both variants separately. git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2540 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 4027a38..c533e2d 100644
--- a/Makefile
+++ b/Makefile
@@ -15,14 +15,13 @@
include Makefile.config
-DIRS=lib common $(ARCH)/$(VARIANT) $(ARCH) backend cfrontend driver \
+DIRS=lib common $(ARCH) backend cfrontend driver \
flocq/Core flocq/Prop flocq/Calc flocq/Appli exportclight \
cparser cparser/validator
RECDIRS=lib common backend cfrontend driver flocq exportclight cparser
COQINCLUDES=$(foreach d, $(RECDIRS), -R $(d) -as compcert.$(d)) \
- -I $(ARCH)/$(VARIANT) -as compcert.$(ARCH).$(VARIANT) \
-I $(ARCH) -as compcert.$(ARCH)
CAMLINCLUDES=$(patsubst %,-I %, $(DIRS)) -I extraction
@@ -241,8 +240,7 @@ cparser/Parser.v: cparser/Parser.vy
depend: $(FILES) exportclight/Clightdefs.v
$(COQDEP) $^ \
- | sed -e 's|$(ARCH)/$(VARIANT)/|$$(ARCH)/$$(VARIANT)/|g' \
- -e 's|$(ARCH)/|$$(ARCH)/|g' \
+ | sed -e 's|$(ARCH)/|$$(ARCH)/|g' \
> .depend
install: