summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-07-23 11:51:33 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-07-23 11:51:33 +0000
commitae6f7b8d4cf30fbc2f56c3f2baa8f028fb7f9c10 (patch)
tree6b04a10541b7d2a582a00b95c1f545eb58afad6d /Makefile
parent2eee425909832e0501e088feaa1fbc8573e877b0 (diff)
Redundant -I in CAMLINCLUDES
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2539 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 6bbf114..4027a38 100644
--- a/Makefile
+++ b/Makefile
@@ -16,7 +16,8 @@
include Makefile.config
DIRS=lib common $(ARCH)/$(VARIANT) $(ARCH) backend cfrontend driver \
- flocq/Core flocq/Prop flocq/Calc flocq/Appli exportclight cparser cparser/validator
+ flocq/Core flocq/Prop flocq/Calc flocq/Appli exportclight \
+ cparser cparser/validator
RECDIRS=lib common backend cfrontend driver flocq exportclight cparser
@@ -24,7 +25,7 @@ COQINCLUDES=$(foreach d, $(RECDIRS), -R $(d) -as compcert.$(d)) \
-I $(ARCH)/$(VARIANT) -as compcert.$(ARCH).$(VARIANT) \
-I $(ARCH) -as compcert.$(ARCH)
-CAMLINCLUDES=$(patsubst %,-I %, $(DIRS)) -I extraction -I cparser
+CAMLINCLUDES=$(patsubst %,-I %, $(DIRS)) -I extraction
MENHIR=menhir
COQC="$(COQBIN)coqc" -q $(COQINCLUDES)