summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-07-23 13:31:59 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-07-23 13:31:59 +0000
commit473454765a4009f5a8ee45ccff728b53c33982bc (patch)
treef0dd97927c1ee9987e23212a37cf744164703632 /Makefile
parent783288d052bbcf75e250dff5018443d109c6101c (diff)
Simplify COQINCLUDES
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2541 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index c533e2d..f698381 100644
--- a/Makefile
+++ b/Makefile
@@ -19,10 +19,9 @@ DIRS=lib common $(ARCH) backend cfrontend driver \
flocq/Core flocq/Prop flocq/Calc flocq/Appli exportclight \
cparser cparser/validator
-RECDIRS=lib common backend cfrontend driver flocq exportclight cparser
+RECDIRS=lib common $(ARCH) backend cfrontend driver flocq exportclight cparser
-COQINCLUDES=$(foreach d, $(RECDIRS), -R $(d) -as compcert.$(d)) \
- -I $(ARCH) -as compcert.$(ARCH)
+COQINCLUDES=$(foreach d, $(RECDIRS), -R $(d) -as compcert.$(d))
CAMLINCLUDES=$(patsubst %,-I %, $(DIRS)) -I extraction