summaryrefslogtreecommitdiff
path: root/Source/Dafny/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Source/Dafny/Makefile')
-rw-r--r--Source/Dafny/Makefile22
1 files changed, 0 insertions, 22 deletions
diff --git a/Source/Dafny/Makefile b/Source/Dafny/Makefile
deleted file mode 100644
index 2013b4f9..00000000
--- a/Source/Dafny/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-COCO = Coco.exe
-
-# ###############################################################################
-# The frame files are no longer in this directory. They must be downloaded
-# from http://boogiepartners.codeplex.com/. Update the FRAME_DIR variable to
-# point to whatever directory you install that into.
-# ###############################################################################
-FRAME_DIR = ..\..\..\boogiepartners\CocoR\Modified
-
-# "all" depends on 2 files, really (Parser.cs and Scanner.cs), but they
-# are both generated in one go and I don't know a better way to tell
-# nmake that. --KRML
-all: Parser.cs
-
-Parser.cs: $(FRAME_DIR)\Scanner.frame $(FRAME_DIR)\Parser.frame Dafny.atg
- $(COCO) Dafny.atg -namespace Microsoft.Dafny -frames $(FRAME_DIR)
-
-clean:
- if exist Scanner.cs del Scanner.cs
- if exist Scanner.cs.old del Scanner.cs.old
- if exist Parser.cs del Parser.cs
- if exist Parser.cs.old del Parser.cs.old