summaryrefslogtreecommitdiff
path: root/Test/Makefile
diff options
context:
space:
mode:
authorGravatar MichalMoskal <unknown>2011-02-18 22:06:06 +0000
committerGravatar MichalMoskal <unknown>2011-02-18 22:06:06 +0000
commitc8c1a544f3db9fd581ab3d84dbdb149dd2d933df (patch)
tree4c2c56f1e139c767b474fcbe3857b6206ee2194a /Test/Makefile
parent9f2b3b64b05d69603ddb222a62b9ed24e4496dab (diff)
Run dafny and boogie tests by default
Diffstat (limited to 'Test/Makefile')
-rw-r--r--Test/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Test/Makefile b/Test/Makefile
index 320e7933..f550eab9 100644
--- a/Test/Makefile
+++ b/Test/Makefile
@@ -3,7 +3,9 @@ LONG = $(shell awk '{ if (tolower($$2) ~ /^long$$/) print $$1 }' $(TESTS_FILE))
NORMAL = $(shell awk '{ if (tolower($$2) ~ /^use$$/) print $$1 }' $(TESTS_FILE))
TESTS = $(NORMAL)
-all: $(addprefix run-, $(TESTS))
+all: boogie dafny
+
+boogie: $(addprefix run-, $(TESTS))
dafny: $(addprefix rundfy-, $(TESTS))