summaryrefslogtreecommitdiff
path: root/Source/Dafny/Makefile
diff options
context:
space:
mode:
authorGravatar rustanleino <unknown>2010-06-24 01:13:16 +0000
committerGravatar rustanleino <unknown>2010-06-24 01:13:16 +0000
commitd6d6e64df3130bae7d28eb165ea861e5eb298464 (patch)
tree74585d4942732de9e6ef72693b5e5e859788927a /Source/Dafny/Makefile
parentcf26b0336a404760302bd57eb822fa906105cf1d (diff)
Dafny:
* re-introduced the feature where an input filename of "stdin.dfy" says to read the program from standard input * supplied missing case (NotInSet) in Compiler.ssc
Diffstat (limited to 'Source/Dafny/Makefile')
-rw-r--r--Source/Dafny/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/Source/Dafny/Makefile b/Source/Dafny/Makefile
index e545fbae..a723042c 100644
--- a/Source/Dafny/Makefile
+++ b/Source/Dafny/Makefile
@@ -1,20 +1,25 @@
COCO = ..\..\Binaries\Coco.exe
-ASML = ..\..\Binaries\asmlc.boot.exe
# ###############################################################################
# The frame files are no longer in this directory. They must be downloaded
# from http://boogiepartners.codeplex.com/ and then copied into this directory.
# ###############################################################################
+FRAME_DIR = c:\boogiepartners\Dafny\Source
# "all" depends on 2 files, really (Parser.cs and Scanner.cs), but they
# are both generated in one go and I don't know a better way to tell
# nmake that. --KRML
all: Parser.ssc
-Parser.ssc: Scanner.frame Parser.frame Dafny.atg
- $(COCO) Dafny.atg -namespace Microsoft.Dafny
+Parser.ssc: $(FRAME_DIR)\Scanner.frame $(FRAME_DIR)\Parser.frame Dafny.atg
+ $(COCO) Dafny.atg -namespace Microsoft.Dafny -frames $(FRAME_DIR)
copy Parser.cs Parser.ssc
copy Scanner.cs Scanner.ssc
clean:
- rm -f Scanner.ssc Parser.ssc
+ if exist Scanner.ssc del Scanner.ssc
+ if exist Scanner.cs del Scanner.cs
+ if exist Scanner.cs.old del Scanner.cs.old
+ if exist Parser.ssc del Parser.ssc
+ if exist Parser.cs del Parser.cs
+ if exist Parser.cs.old del Parser.cs.old