summaryrefslogtreecommitdiff
path: root/Source/Core/Makefile
diff options
context:
space:
mode:
authorGravatar mikebarnett <unknown>2009-07-15 21:03:41 +0000
committerGravatar mikebarnett <unknown>2009-07-15 21:03:41 +0000
commitce1c2de044c91624370411e23acab13b0381949b (patch)
tree592539996fe08050ead5ee210c973801611dde40 /Source/Core/Makefile
Initial set of files.
Diffstat (limited to 'Source/Core/Makefile')
-rw-r--r--Source/Core/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/Source/Core/Makefile b/Source/Core/Makefile
new file mode 100644
index 00000000..ee73b25d
--- /dev/null
+++ b/Source/Core/Makefile
@@ -0,0 +1,18 @@
+COCO = ..\..\Binaries\Coco.exe
+ASML = ..\..\Binaries\asmlc.boot.exe
+
+# "all" depends on 2 files, really (Parser.cs and Scanner.cs), but they
+# are both generated in one go and I don't know a better way to tell
+# nmake that. --KRML
+all: Parser.ssc
+
+#Graph.dll: Graph.as
+# $(ASML) /target:library Graph.as
+
+Parser.ssc: Scanner.frame Parser.frame BoogiePL.atg
+ $(COCO) BoogiePL.atg
+ copy Parser.cs Parser.ssc
+ copy Scanner.cs Scanner.ssc
+
+clean:
+ rm -f Scanner.ssc Parser.ssc