summaryrefslogtreecommitdiff
path: root/Source/Core/Makefile
diff options
context:
space:
mode:
authorGravatar Unknown <leino@LEINO6.redmond.corp.microsoft.com>2012-09-19 14:51:00 -0700
committerGravatar Unknown <leino@LEINO6.redmond.corp.microsoft.com>2012-09-19 14:51:00 -0700
commit3ddba599df3f5cc737216cb8b25f90002893907b (patch)
tree2ae46add23013af0eaac93e483876a60058583ce /Source/Core/Makefile
parent7f821fd8842255765b74b7fc14789fe4364271ce (diff)
Boogie: improved parser makefile
Diffstat (limited to 'Source/Core/Makefile')
-rw-r--r--Source/Core/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Source/Core/Makefile b/Source/Core/Makefile
index 192a16db..4d3f433a 100644
--- a/Source/Core/Makefile
+++ b/Source/Core/Makefile
@@ -10,10 +10,11 @@ FRAME_DIR = ..\..\..\boogiepartners\CocoR\Modified
# "all" depends on 2 files, really (Parser.cs and Scanner.cs), but they
# are both generated in one go and I don't know a better way to tell
# nmake that. --KRML
-all: Parser.ssc
+all: Parser.cs
-Parser.ssc: $(FRAME_DIR)\Scanner.frame $(FRAME_DIR)\Parser.frame BoogiePL.atg
+Parser.cs: $(FRAME_DIR)\Scanner.frame $(FRAME_DIR)\Parser.frame BoogiePL.atg
$(COCO) BoogiePL.atg -namespace Microsoft.Boogie -frames $(FRAME_DIR)
clean:
- rm -f Scanner.cs Parser.cs
+ if exist Scanner.cs del Scanner.cs
+ if exist Parser.cs del Parser.cs