summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar mikebarnett <unknown>2009-08-10 21:48:31 +0000
committerGravatar mikebarnett <unknown>2009-08-10 21:48:31 +0000
commitecdfc58e314d98fcf0616cebc4e411d8aa007df7 (patch)
tree219bd79bfce3d366aad0c5dc8a029371d2fe167b
parentd105ecf9da0cd53a329de6bed90caec85e21774d (diff)
Changes needed in order to build Boogie using a freshly built Spec# compiler and not just the LKG.
-rw-r--r--Binaries/Makefile31
-rw-r--r--Source/Core.sscproj210
-rw-r--r--Source/Core/Xml.ssc1
-rw-r--r--Source/version.ssc4
4 files changed, 33 insertions, 213 deletions
diff --git a/Binaries/Makefile b/Binaries/Makefile
new file mode 100644
index 00000000..14cad08b
--- /dev/null
+++ b/Binaries/Makefile
@@ -0,0 +1,31 @@
+SPECSHARPROOT = d:\SpecSharpCodePlex\SpecSharp
+# Use the first one if you want to build Boogie using the LKG build of Spec#.
+# Use the second one if you want to build Boogie using a freshly built version of Spec#.
+#
+#SPECSHARPBINDIR = Microsoft.SpecSharp\LastKnownGood9
+SPECSHARPBINDIR = Microsoft.SpecSharp\Registration
+
+all:
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\ITaskManager.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\ITaskManager.pdb"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\System.Compiler.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\System.Compiler.pdb"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\System.Compiler.Framework.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\System.Compiler.Framework.pdb"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\System.Compiler.Runtime.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\System.Compiler.Runtime.pdb"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\Microsoft.SpecSharp.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\Microsoft.SpecSharp.pdb"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\Microsoft.SpecSharp.Runtime.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\Microsoft.SpecSharp.Runtime.pdb"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\Mscorlib.Contracts.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\System.Contracts.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\System.Xml.Contracts.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\System.Compiler.Contracts.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\System.Compiler.Framework.Contracts.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\Microsoft.VisualStudio.IntegrationHelper.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\Microsoft.VisualStudio.IntegrationHelper.pdb"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\Microsoft.VisualStudio.Package.dll"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\Microsoft.VisualStudio.Package.pdb"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\ssc.exe"
+ copy /y "$(SPECSHARPROOT)\$(SPECSHARPBINDIR)\ssc.pdb"
diff --git a/Source/Core.sscproj b/Source/Core.sscproj
deleted file mode 100644
index f1b7aea7..00000000
--- a/Source/Core.sscproj
+++ /dev/null
@@ -1,210 +0,0 @@
-<?xml version="1.0" encoding="utf-8"?>
-<VisualStudioProject>
- <XEN ProjectType="Local"
- SchemaVersion="1.0"
- Name="Core"
- ProjectGuid="47bc34f1-a173-40be-84c2-9332b4418387"
- >
- <Build>
- <Settings ApplicationIcon=""
- AssemblyName="Core"
- OutputType="Library"
- RootNamespace="Core"
- StartupObject=""
- TargetPlatform="v2"
- TargetPlatformLocation=""
- ShadowedAssembly=""
- StandardLibraryLocation=""
- >
- <Config Name="Debug"
- AllowUnsafeBlocks="False"
- BaseAddress="285212672"
- CheckForOverflowUnderflow="False"
- ConfigurationOverrideFile=""
- DefineConstants="DEBUG;TRACE;WHIDBEY"
- DocumentationFile=""
- DebugSymbols="True"
- FileAlignment="4096"
- IncrementalBuild="True"
- Optimize="False"
- OutputPath="bin\Debug"
- RegisterForComInterop="False"
- RemoveIntegerChecks="false"
- TreatWarningsAsErrors="False"
- WarningLevel="4"
- RunProgramVerifier="False"
- ProgramVerifierCommandLineOptions=""
- ReferenceTypesAreNonNullByDefault="False"
- RunProgramVerifierWhileEditing="False"
- AllowPointersToManagedStructures="False"
- CheckContractAdmissibility="True"
- CheckPurity="False"
- DisableAssumeChecks="False"
- DisableDefensiveChecks="False"
- DisableGuardedClassesChecks="False"
- DisableInternalChecks="False"
- DisableInternalContractsMetadata="False"
- DisablePublicContractsMetadata="False"
- DebugMode="Project"
- StartProgram=""
- StartURL=""
- StartPage=""
- CmdArgs="houd1.bpl /Houdini /prover:z3api"
- WorkingDirectory="c:\boogie\test\houdini"
- UseIE="False"
- EnableRemoteDebugging="False"
- RemoteDebugMachine=""
- />
- <Config Name="Release"
- AllowUnsafeBlocks="false"
- BaseAddress="285212672"
- CheckForOverflowUnderflow="false"
- ConfigurationOverrideFile=""
- DefineConstants="TRACE;WHIDBEY"
- DocumentationFile=""
- DebugSymbols="false"
- FileAlignment="4096"
- IncrementalBuild="false"
- Optimize="true"
- OutputPath="bin\release"
- RegisterForComInterop="false"
- RemoveIntegerChecks="false"
- TreatWarningsAsErrors="True"
- WarningLevel="4"
- />
- </Settings>
- <References>
- <Reference Name="Mscorlib.Contracts"
- AssemblyName="Mscorlib.Contracts"
- Private="false"
- HintPath="C:/Program Files/Microsoft/Spec#/bin/Mscorlib.Contracts.dll"
- />
- <Reference Name="System"
- AssemblyName="System"
- Private="false"
- />
- <Reference Name="System.Compiler.Framework"
- AssemblyName="System.Compiler.Framework"
- Private="true"
- HintPath="C:/Program Files/Microsoft/Spec#/bin/System.Compiler.Framework.dll"
- />
- <Reference Name="AIFramework"
- Project="{24B55172-AD8B-47D1-8952-5A95CFDB9B31}"
- Private="true"
- />
- <Reference Name="System.Compiler"
- AssemblyName="System.Compiler"
- Private="true"
- HintPath="C:/Program Files/Microsoft/Spec#/bin/System.Compiler.dll"
- />
- <Reference Name="Graph"
- Project="{4C28FB90-630E-4B55-A937-11A011B79765}"
- Private="true"
- />
- <Reference Name="System.XML"
- AssemblyName="System.XML"
- Private="false"
- HintPath="C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/System.XML.dll"
- />
- <Reference Name="System.Xml.Contracts"
- AssemblyName="System.Xml.Contracts"
- Private="true"
- HintPath="C:/Program Files/Microsoft/Spec#/bin/System.Xml.Contracts.dll"
- />
- <Reference Name="FSharp.Core"
- AssemblyName="FSharp.Core"
- Private="true"
- HintPath="C:/Program Files/FSharp-1.9.6.16/bin/FSharp.Core.dll"
- />
- <Reference Name="Basetypes"
- Project="{0C692837-77EC-415F-BF04-395E3ED06E9A}"
- Private="true"
- />
- </References>
- </Build>
- <Files>
- <Include>
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="Absy.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="..\version.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="Duplicator.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="OOLongUtil.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="PureCollections.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="ResolutionContext.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="StandardVisitor.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="Util.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="CommandLineOptions.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="scanner.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="parser.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="GraphAlgorithms.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="AbsyType.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="AbsyCmd.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="AbsyExpr.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="Xml.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="Inline.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="LoopUnroll.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="VCExp.ssc"
- />
- <File BuildAction="Compile"
- SubType="Code"
- RelPath="TypeAmbiguitySeeker.ssc"
- />
- </Include>
- </Files>
- </XEN>
-</VisualStudioProject> \ No newline at end of file
diff --git a/Source/Core/Xml.ssc b/Source/Core/Xml.ssc
index 5714849c..4dadaf8c 100644
--- a/Source/Core/Xml.ssc
+++ b/Source/Core/Xml.ssc
@@ -281,7 +281,6 @@ namespace Microsoft.Boogie
}
public void Dispose()
- modifies this.*, sink.*;
{
if (sink != null) {
assume sink.IsOpen;
diff --git a/Source/version.ssc b/Source/version.ssc
index bad3d890..a62185e7 100644
--- a/Source/version.ssc
+++ b/Source/version.ssc
@@ -4,5 +4,5 @@
//
//-----------------------------------------------------------------------------
using System.Reflection;
-[assembly: AssemblyVersion("1.0.21125.0")]
-[assembly: AssemblyFileVersion("1.0.21125.0")]
+[assembly: AssemblyVersion("1.0.21126.0")]
+[assembly: AssemblyFileVersion("1.0.21126.0")]