summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2022-02-04 13:10:56 -0500
committerGravatar Benjamin Barenblat <bbaren@google.com>2022-02-04 13:10:56 -0500
commit4528db7949c7992f4c35c6728b53da7799e5b8b3 (patch)
tree6416fe53e9db7871d7b90fd35c8f92099ae709ca /debian/rules
parent6cf15f81f3f23bf47e83fa38180c92dc5afd27f1 (diff)
Reenable unit tests on most architectures
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 7 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index f8fc5082..ef27843d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,11 +17,14 @@ include /usr/share/dpkg/architecture.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow reproducible=+fixfilepath
-# Unit tests aren't working on all platforms yet.
-ifneq ($(filter $(DEB_HOST_ARCH),amd64 arm64 mips64el ppc64el s390x),)
-ABSL_RUN_TESTS=ON
-else
+# Unit tests require more than 2 GB of RAM, so disable them on mipsel.
+#
+# Unit tests are not yet passing on hppa or ppc64, so disable them there as
+# well.
+ifneq ($(filter $(DEB_HOST_ARCH),hppa mipsel ppc64),)
ABSL_RUN_TESTS=OFF
+else
+ABSL_RUN_TESTS=ON
endif
%: