summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2022-02-04 13:10:56 -0500
committerGravatar Benjamin Barenblat <bbaren@google.com>2022-02-04 13:10:56 -0500
commit4528db7949c7992f4c35c6728b53da7799e5b8b3 (patch)
tree6416fe53e9db7871d7b90fd35c8f92099ae709ca
parent6cf15f81f3f23bf47e83fa38180c92dc5afd27f1 (diff)
Reenable unit tests on most architectures
-rw-r--r--debian/changelog2
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules11
3 files changed, 9 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 296446b0..7913fc07 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,7 +8,7 @@ abseil (0~20210324.2-1) UNRELEASED; urgency=medium
debian/changelog.
* Stop forcing -Wl,--no-as-needed on dependents. (Closes: #1001596)
* Compute Thumb function bounds correctly. (Closes: #987314)
- * Reenable unit tests on arm64, mips64el, and s390x.
+ * Reenable unit tests on most architectures.
-- Benjamin Barenblat <bbaren@debian.org> Thu, 08 Apr 2021 10:28:01 -0400
diff --git a/debian/control b/debian/control
index 4acf655a..4fb9a17c 100644
--- a/debian/control
+++ b/debian/control
@@ -18,7 +18,7 @@ Maintainer: Benjamin Barenblat <bbaren@debian.org>
Build-Depends:
cmake (>= 3.5),
debhelper-compat (= 12),
- googletest (>= 1.10.0.20200926) [amd64 arm64 mips64el ppc64el s390x],
+ googletest (>= 1.10.0.20200926) [!hppa !mipsel !ppc64]
Rules-Requires-Root: no
Standards-Version: 4.5.1
Section: libs
diff --git a/debian/rules b/debian/rules
index f8fc5082..ef27843d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,11 +17,14 @@ include /usr/share/dpkg/architecture.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow reproducible=+fixfilepath
-# Unit tests aren't working on all platforms yet.
-ifneq ($(filter $(DEB_HOST_ARCH),amd64 arm64 mips64el ppc64el s390x),)
-ABSL_RUN_TESTS=ON
-else
+# Unit tests require more than 2 GB of RAM, so disable them on mipsel.
+#
+# Unit tests are not yet passing on hppa or ppc64, so disable them there as
+# well.
+ifneq ($(filter $(DEB_HOST_ARCH),hppa mipsel ppc64),)
ABSL_RUN_TESTS=OFF
+else
+ABSL_RUN_TESTS=ON
endif
%: