summaryrefslogtreecommitdiff
path: root/absl/time
diff options
context:
space:
mode:
authorGravatar Eduardo Menges Mattje <50274155+EduMenges@users.noreply.github.com>2024-07-11 08:17:56 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2024-07-11 08:18:50 -0700
commitdb1255ca30db1cfcc411eddb74368911f505136c (patch)
tree86879367c20e55a33d7e4ccbfdb13b3ee424bc1c /absl/time
parentcd7f66cab520e99531979b3fd727a25616a1ccbb (diff)
PR #1695: Fix time library build for Apple platforms
Imported from GitHub PR https://github.com/abseil/abseil-cpp/pull/1695 #1495 converted the `if (APPLE)` check for linking against `CoreFoundation` to generator expressions, which is fine and all. The issue is that they forgot the other Apple platforms, making builds for iOS impossible. This patch fixes this issue by adding the other Apple platforms that CMake support to the generator expression. Merge 4f01df8e09f0dc216006dd7ca2d9ce216122b443 into 6dee153242d7becebe026a9bed52f4114441719d Merging this change closes #1695 COPYBARA_INTEGRATE_REVIEW=https://github.com/abseil/abseil-cpp/pull/1695 from GeniusVentures:fix-time-build 4f01df8e09f0dc216006dd7ca2d9ce216122b443 PiperOrigin-RevId: 651416278 Change-Id: I47e4d52384e946cc9e421922f7c6edd5bfa1d976
Diffstat (limited to 'absl/time')
-rw-r--r--absl/time/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/absl/time/CMakeLists.txt b/absl/time/CMakeLists.txt
index e1ade7a3..fe625f28 100644
--- a/absl/time/CMakeLists.txt
+++ b/absl/time/CMakeLists.txt
@@ -83,7 +83,7 @@ absl_cc_library(
Threads::Threads
# TODO(#1495): Use $<LINK_LIBRARY:FRAMEWORK,CoreFoundation> once our
# minimum CMake version >= 3.24
- $<$<PLATFORM_ID:Darwin>:-Wl,-framework,CoreFoundation>
+ $<$<PLATFORM_ID:Darwin,iOS,tvOS,visionOS,watchOS>:-Wl,-framework,CoreFoundation>
)
# Internal-only target, do not depend on directly.