summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Derek Mauro <761129+derekmauro@users.noreply.github.com>2023-01-25 11:31:08 -0500
committerGravatar GitHub <noreply@github.com>2023-01-25 11:31:08 -0500
commit78be63686ba732b25052be15f8d6dee891c05749 (patch)
tree0ccd7bfcf02bd54bfd512867632b46c4315e063a /CMakeLists.txt
parenta69b0ae5cdba53a45617afc408618a3e1ac244de (diff)
Apply LTS transformations for 20230125 LTS branch (#1370)20230125.rc320230125.0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 2 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e102578..3a9e521f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,7 +48,7 @@ if (POLICY CMP0067)
cmake_policy(SET CMP0067 NEW)
endif (POLICY CMP0067)
-project(absl LANGUAGES CXX)
+project(absl LANGUAGES CXX VERSION 20230125)
include(CTest)
# Output directory is correct by default for most build setups. However, when
@@ -176,17 +176,7 @@ endif()
add_subdirectory(absl)
if(ABSL_ENABLE_INSTALL)
- # absl:lts-remove-begin(system installation is supported for LTS releases)
- # We don't support system-wide installation
- list(APPEND SYSTEM_INSTALL_DIRS "/usr/local" "/usr" "/opt/" "/opt/local" "c:/Program Files/${PROJECT_NAME}")
- if(NOT DEFINED CMAKE_INSTALL_PREFIX OR CMAKE_INSTALL_PREFIX IN_LIST SYSTEM_INSTALL_DIRS)
- message(WARNING "\
- The default and system-level install directories are unsupported except in LTS \
- releases of Abseil. Please set CMAKE_INSTALL_PREFIX to install Abseil in your \
- source or build tree directly.\
- ")
- endif()
- # absl:lts-remove-end
+
# install as a subdirectory only
install(EXPORT ${PROJECT_NAME}Targets