summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Derek Mauro <761129+derekmauro@users.noreply.github.com>2023-01-25 11:31:08 -0500
committerGravatar GitHub <noreply@github.com>2023-01-25 11:31:08 -0500
commit78be63686ba732b25052be15f8d6dee891c05749 (patch)
tree0ccd7bfcf02bd54bfd512867632b46c4315e063a
parenta69b0ae5cdba53a45617afc408618a3e1ac244de (diff)
Apply LTS transformations for 20230125 LTS branch (#1370)20230125.rc320230125.0
-rw-r--r--CMake/AbseilHelpers.cmake2
-rw-r--r--CMakeLists.txt14
-rw-r--r--WORKSPACE6
-rw-r--r--absl/base/config.h4
-rw-r--r--absl/base/options.h4
-rw-r--r--ci/cmake_common.sh2
6 files changed, 11 insertions, 21 deletions
diff --git a/CMake/AbseilHelpers.cmake b/CMake/AbseilHelpers.cmake
index 0c91aadf..6d059e7e 100644
--- a/CMake/AbseilHelpers.cmake
+++ b/CMake/AbseilHelpers.cmake
@@ -311,7 +311,7 @@ Cflags: -I\${includedir}${PC_CFLAGS}\n")
if(ABSL_ENABLE_INSTALL)
set_target_properties(${_NAME} PROPERTIES
OUTPUT_NAME "absl_${_NAME}"
- SOVERSION 0
+ SOVERSION "2301.0.0"
)
endif()
else()
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e102578..3a9e521f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,7 +48,7 @@ if (POLICY CMP0067)
cmake_policy(SET CMP0067 NEW)
endif (POLICY CMP0067)
-project(absl LANGUAGES CXX)
+project(absl LANGUAGES CXX VERSION 20230125)
include(CTest)
# Output directory is correct by default for most build setups. However, when
@@ -176,17 +176,7 @@ endif()
add_subdirectory(absl)
if(ABSL_ENABLE_INSTALL)
- # absl:lts-remove-begin(system installation is supported for LTS releases)
- # We don't support system-wide installation
- list(APPEND SYSTEM_INSTALL_DIRS "/usr/local" "/usr" "/opt/" "/opt/local" "c:/Program Files/${PROJECT_NAME}")
- if(NOT DEFINED CMAKE_INSTALL_PREFIX OR CMAKE_INSTALL_PREFIX IN_LIST SYSTEM_INSTALL_DIRS)
- message(WARNING "\
- The default and system-level install directories are unsupported except in LTS \
- releases of Abseil. Please set CMAKE_INSTALL_PREFIX to install Abseil in your \
- source or build tree directly.\
- ")
- endif()
- # absl:lts-remove-end
+
# install as a subdirectory only
install(EXPORT ${PROJECT_NAME}Targets
diff --git a/WORKSPACE b/WORKSPACE
index 1a050544..4069ecc7 100644
--- a/WORKSPACE
+++ b/WORKSPACE
@@ -21,10 +21,10 @@ load("@bazel_tools//tools/build_defs/repo:http.bzl", "http_archive")
# GoogleTest/GoogleMock framework. Used by most unit-tests.
http_archive(
name = "com_google_googletest", # 2023-01-05T19:15:29Z
- sha256 = "1c805208d019aabb8be3cddbc6098be8815ee5cf0a7baf526102528fd624c422",
- strip_prefix = "googletest-934542165899c786cb5d8a710529c37184730183",
+ sha256 = "ffa17fbc5953900994e2deec164bb8949879ea09b411e07f215bfbb1f87f4632",
+ strip_prefix = "googletest-1.13.0",
# Keep this URL in sync with ABSL_GOOGLETEST_COMMIT in ci/cmake_common.sh.
- urls = ["https://github.com/google/googletest/archive/934542165899c786cb5d8a710529c37184730183.zip"],
+ urls = ["https://github.com/google/googletest/archive/refs/tags/v1.13.0.zip"],
)
# RE2 (the regular expression library used by GoogleTest)
diff --git a/absl/base/config.h b/absl/base/config.h
index c2a973af..e35d2e48 100644
--- a/absl/base/config.h
+++ b/absl/base/config.h
@@ -111,8 +111,8 @@
//
// LTS releases can be obtained from
// https://github.com/abseil/abseil-cpp/releases.
-#undef ABSL_LTS_RELEASE_VERSION
-#undef ABSL_LTS_RELEASE_PATCH_LEVEL
+#define ABSL_LTS_RELEASE_VERSION 20230125
+#define ABSL_LTS_RELEASE_PATCH_LEVEL 0
// Helper macro to convert a CPP variable to a string literal.
#define ABSL_INTERNAL_DO_TOKEN_STR(x) #x
diff --git a/absl/base/options.h b/absl/base/options.h
index 5c162a38..b6de636d 100644
--- a/absl/base/options.h
+++ b/absl/base/options.h
@@ -199,8 +199,8 @@
// be changed to a new, unique identifier name. In particular "head" is not
// allowed.
-#define ABSL_OPTION_USE_INLINE_NAMESPACE 0
-#define ABSL_OPTION_INLINE_NAMESPACE_NAME head
+#define ABSL_OPTION_USE_INLINE_NAMESPACE 1
+#define ABSL_OPTION_INLINE_NAMESPACE_NAME lts_20230125
// ABSL_OPTION_HARDENED
//
diff --git a/ci/cmake_common.sh b/ci/cmake_common.sh
index 64317425..373aaa9c 100644
--- a/ci/cmake_common.sh
+++ b/ci/cmake_common.sh
@@ -14,7 +14,7 @@
# The commit of GoogleTest to be used in the CMake tests in this directory.
# Keep this in sync with the commit in the WORKSPACE file.
-readonly ABSL_GOOGLETEST_COMMIT="934542165899c786cb5d8a710529c37184730183"
+readonly ABSL_GOOGLETEST_COMMIT="b796f7d44681514f58a683a3a71ff17c94edb0c1" # v1.13.0
# Avoid depending on GitHub by looking for a cached copy of the commit first.
if [[ -r "${KOKORO_GFILE_DIR:-}/distdir/${ABSL_GOOGLETEST_COMMIT}.zip" ]]; then