summaryrefslogtreecommitdiff
path: root/CMake
diff options
context:
space:
mode:
authorGravatar Derek Mauro <dmauro@google.com>2022-09-07 06:58:32 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2022-09-07 06:59:16 -0700
commitea9c8ff5789bd3ff3ae842903f198700e4e1a11f (patch)
tree50f914a1b8dd423a815a301da3419aa994b90885 /CMake
parent308bbf300fe9332130f4784c7a91fa2ad707d6e4 (diff)
CMake: Require at least CMake 3.10
This is the current minimum according to https://github.com/google/oss-policies-info/blob/main/foundational-cxx-support-matrix.md PiperOrigin-RevId: 472714045 Change-Id: I5930bbbc4eec4644d22bba703957d1764c2e76be
Diffstat (limited to 'CMake')
-rw-r--r--CMake/Googletest/CMakeLists.txt.in2
-rw-r--r--CMake/README.md4
-rw-r--r--CMake/install_test_project/CMakeLists.txt2
3 files changed, 4 insertions, 4 deletions
diff --git a/CMake/Googletest/CMakeLists.txt.in b/CMake/Googletest/CMakeLists.txt.in
index 5769e3a9..75691b11 100644
--- a/CMake/Googletest/CMakeLists.txt.in
+++ b/CMake/Googletest/CMakeLists.txt.in
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 2.8.2)
+cmake_minimum_required(VERSION 3.10)
project(googletest-external NONE)
diff --git a/CMake/README.md b/CMake/README.md
index 0be3b926..19fb327c 100644
--- a/CMake/README.md
+++ b/CMake/README.md
@@ -39,7 +39,7 @@ section of your executable or of your library.<br>
Here is a short CMakeLists.txt example of an application project using Abseil.
```cmake
-cmake_minimum_required(VERSION 3.8.2)
+cmake_minimum_required(VERSION 3.10)
project(my_app_project)
# Pick the C++ standard to compile with.
@@ -62,7 +62,7 @@ will control Abseil library targets) is set to at least that minimum. For
example:
```cmake
-cmake_minimum_required(VERSION 3.8.2)
+cmake_minimum_required(VERSION 3.10)
project(my_lib_project)
# Leave C++ standard up to the root application, so set it only if this is the
diff --git a/CMake/install_test_project/CMakeLists.txt b/CMake/install_test_project/CMakeLists.txt
index b865b2ec..30c23b2c 100644
--- a/CMake/install_test_project/CMakeLists.txt
+++ b/CMake/install_test_project/CMakeLists.txt
@@ -15,7 +15,7 @@
# A simple CMakeLists.txt for testing cmake installation
-cmake_minimum_required(VERSION 3.5)
+cmake_minimum_required(VERSION 3.10)
project(absl_cmake_testing CXX)
add_executable(simple simple.cc)