summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephan Dollberg <stephan.dollberg@gmail.com>2018-09-28 10:35:51 -0700
committerGravatar Derek Mauro <761129+derekmauro@users.noreply.github.com>2018-09-28 13:35:51 -0400
commit5aae0cffae8ffaacab965756169b34e511b353df (patch)
treefdf371d9a014714085978f01b1e1e55f087c771c
parent48cd2c3f351ff188bc85684b84a91b6e6d17d896 (diff)
Fix CMake build (#173)
* Fix CMake build after Swissmap addition `absl::container` library now contains source files so needs to be respectively built for CMake as well. Switches `absl::container` from being a header library to a source library. * Add raw_hash_set_test to CMake test build
-rw-r--r--absl/container/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 710bace7..455c6f6c 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -47,10 +47,11 @@ list(APPEND CONTAINER_INTERNAL_HEADERS
"internal/unordered_set_modifiers_test.h"
)
-
-absl_header_library(
+absl_library(
TARGET
absl_container
+ SOURCES
+ "internal/raw_hash_set.cc"
EXPORT_NAME
container
)
@@ -164,3 +165,11 @@ absl_test(
)
+absl_test(
+ TARGET
+ raw_hash_set_test
+ SOURCES
+ "internal/raw_hash_set_test.cc"
+ PUBLIC_LIBRARIES
+ absl::base absl::hash absl_throw_delegate test_instance_tracker_lib
+)