summaryrefslogtreecommitdiff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 710bace7..455c6f6c 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -47,10 +47,11 @@ list(APPEND CONTAINER_INTERNAL_HEADERS
"internal/unordered_set_modifiers_test.h"
)
-
-absl_header_library(
+absl_library(
TARGET
absl_container
+ SOURCES
+ "internal/raw_hash_set.cc"
EXPORT_NAME
container
)
@@ -164,3 +165,11 @@ absl_test(
)
+absl_test(
+ TARGET
+ raw_hash_set_test
+ SOURCES
+ "internal/raw_hash_set_test.cc"
+ PUBLIC_LIBRARIES
+ absl::base absl::hash absl_throw_delegate test_instance_tracker_lib
+)