summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules10
1 files changed, 9 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 792a1d2..cf66ba3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,13 +2,21 @@
# -*- makefile -*-
include /usr/share/coq/coqvars.mk
+include /usr/share/ocaml/ocamlvars.mk
+
+ifeq ($(OCAML_NATDYNLINK),yes)
+ TARGET := opt
+else
+ TARGET := byte
+endif
%:
dh $@ --with ocaml
.PHONY: override_dh_auto_build
override_dh_auto_build:
- $(MAKE) world
+ $(MAKE) Makefile.coq
+ $(MAKE) -f Makefile.coq $(TARGET) html
.PHONY: override_dh_auto_install
override_dh_auto_install: