summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2012-09-22 09:30:09 +0000
committerGravatar Stephane Glondu <steph@glondu.net>2012-09-22 16:07:43 +0200
commit4a1335ac502ef0b55e063e24589d0a28b3fa9c5c (patch)
treeae73af2751b078f0d503bf7f1156ba455de3f5c3
parent0ed339960aa5d8016380540a0d4a64abb8333989 (diff)
Fix FTBFS without natdynlink
-rwxr-xr-xdebian/rules10
1 files changed, 9 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 792a1d2..cf66ba3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,13 +2,21 @@
# -*- makefile -*-
include /usr/share/coq/coqvars.mk
+include /usr/share/ocaml/ocamlvars.mk
+
+ifeq ($(OCAML_NATDYNLINK),yes)
+ TARGET := opt
+else
+ TARGET := byte
+endif
%:
dh $@ --with ocaml
.PHONY: override_dh_auto_build
override_dh_auto_build:
- $(MAKE) world
+ $(MAKE) Makefile.coq
+ $(MAKE) -f Makefile.coq $(TARGET) html
.PHONY: override_dh_auto_install
override_dh_auto_install: