summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2019-02-13 20:40:51 -0500
committerGravatar Benjamin Barenblat <bbaren@google.com>2019-02-13 20:40:51 -0500
commit2ee22055c510a56c3d040fe023d0884b183bd68c (patch)
tree595eeed2159e90da8284b9e2d545430a61a60d04 /Makefile
parent7ecbed522b4b4a9829eb9bd7b3f36db53788a77c (diff)
parent8018e923c75eb5504310864f821972f794b7d554 (diff)
Updated version 8.8.0+1.gbp069dc3b from 'upstream/8.8.0+1.gbp069dc3b'
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index abf2ec6..3e77020 100644
--- a/Makefile
+++ b/Makefile
@@ -1,16 +1,16 @@
all: Makefile.coq
- +make -f Makefile.coq all
+ +$(MAKE) -f Makefile.coq all
clean: Makefile.coq
- +make -f Makefile.coq clean
- rm -f Makefile.coq
+ +$(MAKE) -f Makefile.coq cleanall
+ rm -f Makefile.coq Makefile.coq.conf
-Makefile.coq: Make
- $(COQBIN)coq_makefile -f Make -o Makefile.coq
+Makefile.coq: _CoqProject
+ $(COQBIN)coq_makefile -f _CoqProject -o Makefile.coq
-Make: ;
+_CoqProject Makefile: ;
%: Makefile.coq
- +make -f Makefile.coq $@
+ +$(MAKE) -f Makefile.coq $@
.PHONY: all clean