summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2019-02-13 20:40:51 -0500
committerGravatar Benjamin Barenblat <bbaren@google.com>2019-02-13 20:40:51 -0500
commit8018e923c75eb5504310864f821972f794b7d554 (patch)
tree88a55f7c23fcbbea0ff80e406555292049b48dec /Makefile
parent76f9b4cdc5693a6313961e2f91b39ba311857e72 (diff)
New upstream version 8.8.0+1.gbp069dc3bupstream/8.8.0+1.gbp069dc3bupstream
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index abf2ec6..3e77020 100644
--- a/Makefile
+++ b/Makefile
@@ -1,16 +1,16 @@
all: Makefile.coq
- +make -f Makefile.coq all
+ +$(MAKE) -f Makefile.coq all
clean: Makefile.coq
- +make -f Makefile.coq clean
- rm -f Makefile.coq
+ +$(MAKE) -f Makefile.coq cleanall
+ rm -f Makefile.coq Makefile.coq.conf
-Makefile.coq: Make
- $(COQBIN)coq_makefile -f Make -o Makefile.coq
+Makefile.coq: _CoqProject
+ $(COQBIN)coq_makefile -f _CoqProject -o Makefile.coq
-Make: ;
+_CoqProject Makefile: ;
%: Makefile.coq
- +make -f Makefile.coq $@
+ +$(MAKE) -f Makefile.coq $@
.PHONY: all clean