summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Nicolas Braud-Santoni <nicolas@braud-santoni.eu>2016-07-23 16:21:44 -0400
committerGravatar Nicolas Braud-Santoni <nicolas@braud-santoni.eu>2016-07-23 16:21:44 -0400
commit17564e4922acda6b72bf39de7a8c23ed0c0178f6 (patch)
tree9551ca9435f64c019dbef48894f5dd0c64045f1c /Makefile
parenta77bca84565b26aeedec3b210d761240d9d261f4 (diff)
Imported Upstream version 8.5.1
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile38
1 files changed, 9 insertions, 29 deletions
diff --git a/Makefile b/Makefile
index 03775bc..a9d5466 100644
--- a/Makefile
+++ b/Makefile
@@ -1,34 +1,14 @@
-
-
-FILES := coq.mli helper.mli search_monad.mli matcher.mli theory.mli print.mli \
- evm_compute.mli evm_compute.ml \
- coq.ml helper.ml search_monad.ml matcher.ml theory.ml print.ml rewrite.ml4 \
- aac.mlpack \
- AAC.v Instances.v Tutorial.v Caveats.v
-
-ARGS := -R . AAC_tactics
-
-.PHONY: coq clean doc
-
-world: all doc
-
all: Makefile.coq
- $(MAKE) -f Makefile.coq all
-
-install: Makefile.coq
- $(MAKE) -f Makefile.coq install
-
-coq: Makefile.coq
- $(MAKE) -f Makefile.coq
+ +make -f Makefile.coq all
-doc: Makefile.coq
- $(MAKE) -f Makefile.coq html
- $(MAKE) -f Makefile.coq mlihtml
+clean: Makefile.coq
+ +make -f Makefile.coq clean
+ rm -f Makefile.coq
-Makefile.coq: Makefile $(VS)
- coq_makefile $(ARGS) $(FILES) -o Makefile.coq
+Makefile.coq: Make
+ $(COQBIN)coq_makefile -f Make -o Makefile.coq
-clean:: Makefile.coq
- $(MAKE) -f Makefile.coq clean
- rm -f Makefile.coq .depend
+%: Makefile.coq
+ +make -f Makefile.coq $@
+.PHONY: all clean