summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2013-12-05 07:55:11 +0100
committerGravatar Stephane Glondu <steph@glondu.net>2013-12-05 07:55:11 +0100
commita77bca84565b26aeedec3b210d761240d9d261f4 (patch)
treebfa74f2072f5522cf27cb8e076e2d8ef4a4b69e6 /Makefile
parent7242d756645c923803c1ffe130be41114c25185a (diff)
Imported Upstream version 0.4upstream/0.4
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 1043ce9..03775bc 100644
--- a/Makefile
+++ b/Makefile
@@ -1,24 +1,29 @@
-FILES := coq.mli helper.mli search_monad.mli matcher.mli theory.mli print.mli rewrite.mli \
- coq.ml helper.ml search_monad.ml matcher.ml theory.ml print.ml rewrite.ml4 \
+FILES := coq.mli helper.mli search_monad.mli matcher.mli theory.mli print.mli \
+ evm_compute.mli evm_compute.ml \
+ coq.ml helper.ml search_monad.ml matcher.ml theory.ml print.ml rewrite.ml4 \
aac.mlpack \
AAC.v Instances.v Tutorial.v Caveats.v
ARGS := -R . AAC_tactics
-.PHONY: coq clean
+.PHONY: coq clean doc
world: all doc
all: Makefile.coq
$(MAKE) -f Makefile.coq all
+install: Makefile.coq
+ $(MAKE) -f Makefile.coq install
+
coq: Makefile.coq
$(MAKE) -f Makefile.coq
doc: Makefile.coq
$(MAKE) -f Makefile.coq html
+ $(MAKE) -f Makefile.coq mlihtml
Makefile.coq: Makefile $(VS)
coq_makefile $(ARGS) $(FILES) -o Makefile.coq