summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Jonathan D Reed <jdreed@mit.edu>2013-03-19 19:56:07 +0000
committerGravatar Jonathan D Reed <jdreed@mit.edu>2013-03-19 19:56:07 +0000
commit12881d396796709fc93f0d327b9e013706f1a8e8 (patch)
treea30d32102409e4ea24cf1a280c1716f09b810ed0 /debian/rules
parent79334b1fa74a9eac8c0512ce80b9611d6f53df2b (diff)
In extra-software:
* Recommend motif-clients (Trac: #946) * Convert from CDBS to dh7 * Remove X-Debathena-Nobuild line now that hardy isn't a thing * Explicitly depend on icedtea6-plugin, as there are no releases without it anymore. * Bump Standards-Version to 3.9.3 * Change copyright file to new copyright format
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 10 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index a36b0b0..2726fd3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,22 +1,20 @@
#!/usr/bin/make -f
-HAVE_ICEDTEA = $(shell apt-cache show icedtea6-plugin 2>/dev/null | grep -q '^Version:' && echo y)
-HAVE_LIBREOFFICE = $(shell apt-cache show libreoffice 2>/dev/null | grep -q '^Version:' && echo y)
+%:
+ dh $@
-include /usr/share/cdbs/1/rules/debhelper.mk
+HAVE_LIBREOFFICE = $(shell apt-cache show libreoffice 2>/dev/null | grep -q '^Version:' && echo y)
-ifeq ($(HAVE_ICEDTEA),y)
- binary-predeb/debathena-extra-software::
- echo "debathena-java-plugin=icedtea6-plugin" >> debian/debathena-extra-software.substvars
+override_dh_gencontrol:
+ifeq ($(HAVE_LIBREOFFICE),y)
+ dh_gencontrol -- -Vdebathena-cool-kids-office-suite=libreoffice
+else
+ dh_gencontrol -- -Vdebathena-cool-kids-office-suite=openoffice.org
endif
ifeq ($(HAVE_LIBREOFFICE),y)
- install/debathena-extra-software::
+override_dh_install:
+ dh_install
dh_install debian/ooffice usr/bin
- binary-predeb/debathena-extra-software::
- echo "debathena-cool-kids-office-suite=libreoffice" >> debian/debathena-extra-software.substvars
-else
- binary-predeb/debathena-extra-software::
- echo "debathena-cool-kids-office-suite=openoffice.org" >> debian/debathena-extra-software.substvars
endif