aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Kevin Hartman <kevin@hart.mn>2014-08-21 00:27:53 -0700
committerGravatar Kevin Hartman <kevin@hart.mn>2014-08-25 20:56:59 -0700
commitcbfd6b6e52e3b8c1d6324d86461f4e8aa240a756 (patch)
tree31355774610d25174521e88ca7dcebfe5bbfe715 /src/video_core/CMakeLists.txt
parentaa7472057ae9b56e3f7216931cbb9e927e39a930 (diff)
Rewrite of OpenGL renderer, including OS X support
Screen contents are now displayed using textured quads. This can be updated to expose an FBO once an OpenGL backend for when Pica rendering is being worked on. That FBO's texture can then be applied to the quads. Previously, FBO blitting was used in order to display screen contents, which did not work on OS X. The new textured quad approach is less of a compatibility risk.
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 71a1b5ec..0d737573 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -5,8 +5,9 @@ set(SRCS clipper.cpp
utils.cpp
vertex_shader.cpp
video_core.cpp
- debug_utils/debug_utils.cpp
- renderer_opengl/renderer_opengl.cpp)
+ renderer_opengl/renderer_opengl.cpp
+ renderer_opengl/gl_shader_util.cpp
+ debug_utils/debug_utils.cpp)
set(HEADERS clipper.h
command_processor.h
@@ -18,7 +19,9 @@ set(HEADERS clipper.h
renderer_base.h
vertex_shader.h
video_core.h
- debug_utils/debug_utils.h
- renderer_opengl/renderer_opengl.h)
+ renderer_opengl/renderer_opengl.h
+ renderer_opengl/gl_shader_util.h
+ renderer_opengl/gl_shaders.h
+ debug_utils/debug_utils.h)
add_library(video_core STATIC ${SRCS} ${HEADERS})