aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-08-23 21:00:08 -0300
committerGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-09-01 17:41:56 -0300
commit478289140daae28cf7eabf54af3addf476aaad9c (patch)
treede13d92f26abaaf5eb0348ae35b2d1c23be497c7 /src/video_core/CMakeLists.txt
parent76372feb1959c0f53d02c2278ef4a14b794a808d (diff)
Replace GLEW with a glLoadGen loader.
This should fix the GL loading errors that occur in some drivers due to the use of deprecated functions by GLEW. Side benefits are more accurate auto-completion (deprecated function and symbols don't exist) and faster pointer loading (less entrypoints to load). In addition it removes an external library depency, simplifying the build system a bit and eliminating one set of binary libraries for Windows.
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 0d737573..48c5d142 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -5,6 +5,7 @@ set(SRCS clipper.cpp
utils.cpp
vertex_shader.cpp
video_core.cpp
+ renderer_opengl/generated/gl_3_2_core.c
renderer_opengl/renderer_opengl.cpp
renderer_opengl/gl_shader_util.cpp
debug_utils/debug_utils.cpp)
@@ -19,6 +20,7 @@ set(HEADERS clipper.h
renderer_base.h
vertex_shader.h
video_core.h
+ renderer_opengl/generated/gl_3_2_core.h
renderer_opengl/renderer_opengl.h
renderer_opengl/gl_shader_util.h
renderer_opengl/gl_shaders.h