aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Johannes Ekberg <uppfinnarn@gmail.com>2014-12-25 11:49:00 +0100
committerGravatar Johannes Ekberg <uppfinnarn@gmail.com>2015-01-09 15:50:46 +0100
commitd7ad14ae2088789a853d36fb3a465a920c0116ee (patch)
tree0fcbc50097f50ac5e460467a3ea89cdf5fc2e91c /CMakeLists.txt
parent13518198109fad9f19cc81aa1d06c3d85d1126f5 (diff)
Use -pthread where and only where needed
Passing -pthread to GCC as a flag makes it both link to libpthread, and make C standard library routines reentrant. This makes the additional explicit links unnecessary. Additionally, on OSX, this is the default behavior, and clang will print a message about it being unused if it's present there.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c6423909..81a793dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,7 +6,11 @@ project(citra)
if (NOT MSVC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wno-attributes")
- add_definitions(-pthread)
+
+ if (NOT APPLE)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
+ endif()
else()
# Silence deprecation warnings
add_definitions(/D_CRT_SECURE_NO_WARNINGS)