aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Johannes Ekberg <uppfinnarn@gmail.com>2014-12-24 10:40:26 +0100
committerGravatar Johannes Ekberg <uppfinnarn@gmail.com>2015-01-09 15:50:46 +0100
commit13518198109fad9f19cc81aa1d06c3d85d1126f5 (patch)
treed000eafcf25727e8ffc2dc6af4eafebcb779d3f0 /CMakeLists.txt
parent7d7ab70279df554959eec29ff43a2eb304a3d578 (diff)
Link Cocoa, IOKit and CoreVideo on OSX
These are implicitly linked by Xcode, but with this, you can also build it with any other generator, which does not have this behavior. CoreFoundation is included as a part of Cocoa (which is an umbrella framework), and Cocoa is generally recommended to link against, rather than its individual components (CoreFoundation, Foundation, libobjc, ...).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36b9344e..c6423909 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -106,9 +106,10 @@ if (ENABLE_GLFW)
endif()
IF (APPLE)
- # CoreFoundation is required only on OSX
- FIND_LIBRARY(COREFOUNDATION_LIBRARY CoreFoundation)
- SET(PLATFORM_LIBRARIES iconv ${COREFOUNDATION_LIBRARY})
+ FIND_LIBRARY(COCOA_LIBRARY Cocoa) # Umbrella framework for everything GUI-related
+ FIND_LIBRARY(IOKIT_LIBRARY IOKit) # GLFW dependency
+ FIND_LIBRARY(COREVIDEO_LIBRARY CoreVideo) # GLFW dependency
+ set(PLATFORM_LIBRARIES iconv ${COCOA_LIBRARY} ${IOKIT_LIBRARY} ${COREVIDEO_LIBRARY})
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -stdlib=libc++")