aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2015-01-13 17:47:45 -0200
committerGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2015-01-19 19:40:43 -0200
commit8c39324333a7f16e5c4161f5e62dbef3e9721330 (patch)
treedec8d514f171128c77f970c78a6498648aabe36a /CMakeLists.txt
parent555c82739e78158a841b7bd77da92631cba5d544 (diff)
CMake: Inform the user when architecture auto-detection fails
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a743a210..567e9533 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,8 +66,11 @@ if (ENABLE_GLFW)
if (MSVC)
if (CMAKE_SIZEOF_VOID_P EQUAL 8)
set(TMP_ARCH "x64")
- else()
+ elseif (CMAKE_SIZEOF_VOID_P EQUAL 4)
set(TMP_ARCH "Win32")
+ else()
+ set(TMP_ARCH "UNKNOWN")
+ message(SEND_ERROR "Couldn't detect your compiler's architecture, you'll have to manually specify the GLFW library to use. (Try checking CMakeOutput.log to find out why.)")
endif()
if (MSVC11) # Visual C++ 2012
@@ -84,8 +87,11 @@ if (ENABLE_GLFW)
# Assume mingw
if (CMAKE_SIZEOF_VOID_P EQUAL 8)
set(TMP_ARCH "x86_64")
- else()
+ elseif (CMAKE_SIZEOF_VOID_P EQUAL 4)
set(TMP_ARCH "i686")
+ else()
+ set(TMP_ARCH "UNKNOWN")
+ message(SEND_ERROR "Couldn't detect your compiler's architecture, you'll have to manually specify the GLFW library to use.")
endif()
set(TMP_TOOLSET "mingw-${TMP_ARCH}")