aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-12-21 05:22:00 -0200
committerGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-12-21 21:26:52 -0200
commit361735e7fe1369d88752f1366f56c8a4ce8c7431 (patch)
tree96b27af79fd2f8442068e6de00da830cae769b7a /CMakeLists.txt
parented8f32f03ef01f61f76b5c4dc02abd6f516cd4bb (diff)
CMake: Silence PNG not found error
Hopefully this will make people stop thinking it's a hard dependency.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af53bda7..1491df6e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,10 +33,12 @@ else()
endif()
add_definitions(-DSINGLETHREADED)
-find_package(PNG)
+find_package(PNG QUIET)
if (PNG_FOUND)
add_definitions(-DHAVE_PNG)
-endif ()
+else()
+ message(STATUS "libpng not found. Some debugging features have been disabled.")
+endif()
find_package(Boost)
if (Boost_FOUND)