aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-12-21 05:18:12 -0200
committerGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-12-21 21:26:51 -0200
commited8f32f03ef01f61f76b5c4dc02abd6f516cd4bb (patch)
treebd93a480ab1f678d1eadf9dff851e066d4f936e1 /CMakeLists.txt
parentc1072491030867d24a276ed803736ffbc1c24355 (diff)
CMake: Use improved optimization flags on MSVC
While not having a noticeable effect on CPU-bound applications, this change gives an about 30-50% increase in performance for games using the GPU.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 638b468a..af53bda7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,25 @@ else()
add_definitions(/D_CRT_SECURE_NO_WARNINGS)
# set up output paths for executable binaries (.exe-files, and .dll-files on DLL-capable platforms)
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
+
+ # Tweak optimization settings
+ # As far as I can tell, there's no way to override the CMake defaults while leaving user
+ # changes intact, so we'll just clobber everything and say sorry.
+ message(STATUS "Cache compiler flags ignored, please edit CMakeFiles.txt to change the flags.")
+ # /MD - Multi-threaded runtime
+ # /Ox - Full optimization
+ # /Oi - Use intrinsic functions
+ # /Oy- - Don't omit frame pointer
+ # /GR- - Disable RTTI
+ # /GS- - No stack buffer overflow checks
+ # /EHsc - C++-only exception handling semantics
+ set(optimization_flags "/MD /Ox /Oi /Oy- /DNDEBUG /GR- /GS- /EHsc")
+ # /Zi - Output debugging information
+ # /Zo - enahnced debug info for optimized builds
+ set(CMAKE_C_FLAGS_RELEASE "${optimization_flags} /Zi" CACHE STRING "" FORCE)
+ set(CMAKE_CXX_FLAGS_RELEASE "${optimization_flags} /Zi" CACHE STRING "" FORCE)
+ set(CMAKE_C_FLAGS_RELWITHDEBINFO "${optimization_flags} /Zi /Zo" CACHE STRING "" FORCE)
+ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${optimization_flags} /Zi /Zo" CACHE STRING "" FORCE)
endif()
add_definitions(-DSINGLETHREADED)