aboutsummaryrefslogtreecommitdiffhomepage
path: root/third_party/py/gflags/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/py/gflags/setup.py')
-rwxr-xr-x[-rw-r--r--]third_party/py/gflags/setup.py28
1 files changed, 10 insertions, 18 deletions
diff --git a/third_party/py/gflags/setup.py b/third_party/py/gflags/setup.py
index 663121a7d4..573db2d410 100644..100755
--- a/third_party/py/gflags/setup.py
+++ b/third_party/py/gflags/setup.py
@@ -1,5 +1,7 @@
#!/usr/bin/env python
-# Copyright 2007 Google Inc. All rights reserved.
+
+# Copyright (c) 2007, Google Inc.
+# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions are
@@ -27,26 +29,16 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-"""Setup module for python-gflags."""
-
-from distutils.core import setup
+from setuptools import setup
setup(name='python-gflags',
- version='3.1.0',
+ version='2.0',
description='Google Commandline Flags Module',
license='BSD',
author='Google Inc. and others',
author_email='google-gflags@googlegroups.com',
- url='https://github.com/google/python-gflags',
- packages=['gflags', 'gflags.third_party', 'gflags.third_party.pep257'],
- data_files=[('bin', ['gflags2man.py'])],
- requires=['six'],
- classifiers=[
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3.4',
- 'Intended Audience :: Developers',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'License :: OSI Approved :: BSD License',
- 'Operating System :: OS Independent',
- ]
- )
+ url='http://code.google.com/p/python-gflags',
+ py_modules=["gflags", "gflags_validators"],
+ data_files=[("bin", ["gflags2man.py"])],
+ include_package_data=True,
+ )