aboutsummaryrefslogtreecommitdiffhomepage
path: root/third_party/py/abseil/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/py/abseil/setup.py')
-rw-r--r--third_party/py/abseil/setup.py61
1 files changed, 61 insertions, 0 deletions
diff --git a/third_party/py/abseil/setup.py b/third_party/py/abseil/setup.py
new file mode 100644
index 0000000000..cc596671cb
--- /dev/null
+++ b/third_party/py/abseil/setup.py
@@ -0,0 +1,61 @@
+# Copyright 2017 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+"""Abseil setup configuration."""
+
+from __future__ import absolute_import
+from __future__ import division
+from __future__ import print_function
+
+import platform
+
+try:
+ import setuptools
+except ImportError:
+ from ez_setup import use_setuptools
+ use_setuptools()
+ import setuptools
+
+py_version = platform.python_version_tuple()
+if py_version < ('2', '7') or py_version[0] == '3' and py_version < ('3', '4'):
+ raise RuntimeError('Python version 2.7 or 3.4+ is required.')
+
+
+setuptools.setup(
+ name='absl-py',
+ version='0.1.1',
+ description='Abseil Python Common Libraries',
+ author='The Abseil Authors',
+ url='https://github.com/abseil/abseil-py',
+ packages=setuptools.find_packages(exclude=[
+ '*.tests', '*.tests.*', 'tests.*', 'tests',
+ ]),
+ install_requires=[
+ 'six',
+ ],
+ license='Apache 2.0',
+ classifiers=[
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Intended Audience :: Developers',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: OS Independent',
+ ],
+)