aboutsummaryrefslogtreecommitdiffhomepage
path: root/scripts/packages/debian
diff options
context:
space:
mode:
authorGravatar Yun Peng <pcloudy@google.com>2016-07-26 13:29:03 +0000
committerGravatar Damien Martin-Guillerez <dmarting@google.com>2016-07-27 11:13:06 +0000
commita50635dbb821aa981fc5245e80a906ce9fd80448 (patch)
tree0059bddc5e0632436e9d775f299de622bb656fea /scripts/packages/debian
parentad81cffc9d9c6234fe22c19bd26523313a82d554 (diff)
Build Bazel debian source package using Bazel
-- Change-Id: I8c0b6adf08a4ca64ad41e0454cb30842c133fa22 Reviewed-on: https://bazel-review.googlesource.com/#/c/4161 MOS_MIGRATED_REVID=128465441
Diffstat (limited to 'scripts/packages/debian')
-rw-r--r--scripts/packages/debian/compat1
-rw-r--r--scripts/packages/debian/control20
-rw-r--r--scripts/packages/debian/copyright35
-rw-r--r--scripts/packages/debian/rules17
4 files changed, 73 insertions, 0 deletions
diff --git a/scripts/packages/debian/compat b/scripts/packages/debian/compat
new file mode 100644
index 0000000000..ec635144f6
--- /dev/null
+++ b/scripts/packages/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/scripts/packages/debian/control b/scripts/packages/debian/control
new file mode 100644
index 0000000000..e03e085b68
--- /dev/null
+++ b/scripts/packages/debian/control
@@ -0,0 +1,20 @@
+Source: bazel
+Section: contrib/devel
+Priority: optional
+Maintainer: The Bazel Authors <bazel-dev@googlegroups.com>
+Build-Depends: dpkg-dev, devscripts
+Standards-Version: 3.9.6
+
+Package: bazel
+Section: contrib/devel
+Priority: optional
+Architecture: amd64
+Depends: java8-jdk | java8-sdk, pkg-config, zip, g++, zlib1g-dev,
+ unzip, bash-completion
+Conflicts: openjdk-9-jdk
+Description: Bazel is a tool that automates software builds and tests.
+ Supported build tasks include running compilers and linkers to produce
+ executable programs and libraries, and assembling deployable packages
+ for Android, iOS and other target environments. Bazel is similar to
+ other tools like Make, Ant, Gradle, Buck, Pants and Maven.
+Homepage: http://bazel.io
diff --git a/scripts/packages/debian/copyright b/scripts/packages/debian/copyright
new file mode 100644
index 0000000000..25981ab8c9
--- /dev/null
+++ b/scripts/packages/debian/copyright
@@ -0,0 +1,35 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: bazel
+Source: https://github.com/bazelbuild/bazel
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
+
+Bazel bundled with software with the following license:
+
+License: 3-clause BSD
+License: 3-clause revised BSD
+License: Apache License 2.0
+License: BSD license
+License: BSD-style license
+License: Eclipse Distribution License 1.0
+License: Eclipse Public License
+License: Eclipse Public License Version 1.0
+License: GNU GPL v2 with Classpath exception
+License: GNU GPL v2 with Classpath exception (plus other licenses, see third_party/java/jdk/langtools/LICENSE file).
+License: GNU GPL v2 with Classpath exception, portions MIT
+License: MIT
+License: MIT license
+License: New BSD License
+License: Public Domain
+
+# Please refer to README.md under third_party/ directory to see which license is used by specific part of code.
diff --git a/scripts/packages/debian/rules b/scripts/packages/debian/rules
new file mode 100644
index 0000000000..eaf895e1aa
--- /dev/null
+++ b/scripts/packages/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_strip:
+
+override_dh_auto_build:
+ ./compile.sh
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -f bazel-*
+ rm -f output
+
+override_dh_install:
+ install -D -m 0755 output/bazel $$(pwd)/debian/bazel/usr/bin/bazel