summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control9
-rwxr-xr-xdebian/rules9
2 files changed, 13 insertions, 5 deletions
diff --git a/debian/control b/debian/control
index dea602d..f964b30 100644
--- a/debian/control
+++ b/debian/control
@@ -3,9 +3,12 @@ Section: net
Priority: optional
Maintainer: Karl Ramm <kcr@debian.org>
Uploaders: Sam Hartman <hartmans@debian.org>
-Build-Depends: debhelper (>= 5), libc-ares-dev, libkrb5-dev (>= 1.2.2-4), comerr-dev, ss-dev,
- libreadline-dev | libreadline5-dev, libx11-dev, libxt-dev, x11proto-core-dev, libncurses5-dev,
- bison, libhesiod-dev, autotools-dev, python (>= 2.5), python-central
+Build-Depends: debhelper (>= 5), libc-ares-dev, libkrb5-dev (>= 1.2.2-4),
+ comerr-dev, ss-dev, libreadline-dev | libreadline5-dev,
+ libx11-dev, libxt-dev, x11proto-core-dev, libncurses5-dev,
+ bison, libhesiod-dev, autotools-dev, python (>= 2.5), python-central,
+ autoconf, libtool
+Build-Conflicts: autoconf2.13
Standards-Version: 3.8.1.0
Homepage: http://zephyr.1ts.org/
Vcs-Svn: svn://zephyr.1ts.org/trunk/zephyr
diff --git a/debian/rules b/debian/rules
index f5af25d..21e597c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,9 +30,9 @@ export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
# FOR AUTOCONF 2.52 AND NEWER ONLY
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
- confflags += --build $(DEB_HOST_GNU_TYPE)
+ CONFIGURE_ROOT += --build $(DEB_HOST_GNU_TYPE)
else
- confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+ CONFIGURE_ROOT += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
endif
BUILD_VARIETALS=$(VARIETALS) no-krb
@@ -61,6 +61,8 @@ configure: configure-stamp autotools
configure-stamp:
dh_testdir
# Add here commands to configure the package.
+ libtoolize -i
+ autoreconf
mkdir -p $(BUILD_VARIETALS)
$(foreach VARIETY,$(BUILD_VARIETALS),(cd $(VARIETY) && CFLAGS="-g -O" ../configure $(CONFIGURE_$(VARIETY)) $(CONFIGURE_ROOT));)
touch configure-stamp
@@ -84,6 +86,9 @@ clean:
-rm -f build-stamp configure-stamp
# Add here commands to clean up after the build process.
+ -rm -rf autom4te.cache m4
+ -rm aclocal.m4 config.guess config.sub configure h/config.h.in \
+ install-sh ltmain.sh
-rm -rf $(VARIETALS) no-krb debian/tmp-krb*
-rm debian/zephyr-server-krb.files
-rm debian/zephyr-server-krb.templates