summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/control16
-rw-r--r--debian/libzephyr-dev.files1
-rw-r--r--debian/libzephyr3.files1
-rwxr-xr-xdebian/rules22
-rw-r--r--debian/zephyr-clients.config (renamed from debian/zephyr-client.config)3
-rw-r--r--debian/zephyr-clients.files (renamed from debian/zephyr-client.files)0
-rw-r--r--debian/zephyr-clients.init (renamed from debian/zephyr-client.init)4
-rw-r--r--debian/zephyr-clients.postinst (renamed from debian/zephyr-client.postinst)12
-rw-r--r--debian/zephyr-clients.prerm (renamed from debian/zephyr-client.prerm)2
-rw-r--r--debian/zephyr-clients.templates (renamed from debian/zephyr-client.templates)2
11 files changed, 53 insertions, 20 deletions
diff --git a/debian/changelog b/debian/changelog
index 5296167..99c5948 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+zephyr (2.1.20000421.SNAPSHOT-8) unstable; urgency=low
+
+ *
+ * zephyr-client -> zephyr-clients
+ * Produce libzephyr3 package and used shared libs
+ * Clean up debian/rules to only call movefiles once
+ * Depend on libxaw-dev for sid/woody
+
+ --
+
zephyr (2.1.20000421.SNAPSHOT-7) unstable; urgency=low
* Fix incorrect potato build-depends (xlib6g-dev instead of xlib6g)
diff --git a/debian/control b/debian/control
index adcd714..afadea7 100644
--- a/debian/control
+++ b/debian/control
@@ -2,10 +2,22 @@ Source: zephyr
Section: unknown
Priority: optional
Maintainer: Karl Ramm <kcr@1ts.org>
-Build-Depends: debhelper, libares-dev, libkrb5-dev, comerr-dev, ss-dev, libreadline4-dev, xlibs-dev | xlib6g-dev, libncurses5-dev, bison
+Build-Depends: debhelper, libares-dev, libkrb5-dev, comerr-dev, ss-dev, libreadline4-dev, xlibs-dev | xlib6g-dev, libxaw-dev|xlib6g-dev, libncurses5-dev, bison
Standards-Version: 3.1.1
-Package: zephyr-client
+Package: libzephyr3
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: The original "Instant Message" system libraries
+ This is the Project Athena Zephyr notification system 2000/04/21 snapshot.
+ Zephyr allows users to send messages to other users or to groups of
+ users. Users can view incoming Zephyr messages as windowgrams
+ (transient X windows) or as text on a terminal.
+
+Package: zephyr-clients
+Provides: zephyr-client
+Replaces: zephyr-client
+Conflicts: zephyr-client
Architecture: any
Depends: ${shlibs:Depends}, debianutils (>= 1.6)
Description: The original "Instant Message" system client
diff --git a/debian/libzephyr-dev.files b/debian/libzephyr-dev.files
index bdd8556..539326d 100644
--- a/debian/libzephyr-dev.files
+++ b/debian/libzephyr-dev.files
@@ -1,4 +1,5 @@
usr/lib/libzephyr.a
+usr/lib/libzephyr.so
usr/include/zephyr/mit-copyright.h
usr/include/zephyr/zephyr.h
usr/include/zephyr/zephyr_err.h
diff --git a/debian/libzephyr3.files b/debian/libzephyr3.files
new file mode 100644
index 0000000..a837249
--- /dev/null
+++ b/debian/libzephyr3.files
@@ -0,0 +1 @@
+usr/lib/libzephyr.so.*
diff --git a/debian/rules b/debian/rules
index 2463bea..2d2fa53 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,7 +14,7 @@ export DH_COMPAT=2
# This has to be exported to make some magic below work.
export DH_OPTIONS
-
+SONAME=3
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -28,7 +28,13 @@ build-stamp:
dh_testdir
# Add here commands to compile the package.
- $(MAKE)
+ -rm -f lib/zephyr/*.o
+ $(MAKE) -C lib \
+ FPIC= \
+ LIBEXT=a
+ rm -f lib/zephyr/*.o
+ $(MAKE) LIBEXT=so \
+ FPIC=-fpic SONAME=$(SONAME)
touch build-stamp
@@ -60,6 +66,8 @@ install: build
# Add here commands to install the package into debian/tmp.
$(MAKE) install DESTDIR=`pwd`/debian/tmp
+ mv debian/tmp/usr/lib/libzephyr.so debian/tmp/usr/lib/libzephyr.so.$(SONAME)
+ ln -s libzephyr.so.$(SONAME) debian/tmp/usr/lib/libzephyr.so
mkdir -p debian/tmp/etc/zephyr/acl
set -x; for i in debian/acl/*; do install -c -m 544 -o root $$i debian/tmp/etc/zephyr/acl; done; set +x
install -c -m 544 debian/zephyr.vars debian/tmp/etc/zephyr
@@ -73,11 +81,8 @@ binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
- dh_movefiles -pzephyr-client
- dh_movefiles -pzephyr-server
- dh_movefiles -plibzephyr-dev
- dh_installdebconf -pzephyr-client
- dh_installdebconf -pzephyr-server
+ dh_movefiles
+ dh_installdebconf
dh_installdocs
# dh_installexamples
# dh_installmenu
@@ -104,4 +109,7 @@ binary-arch: build install
dh_builddeb
binary: binary-indep binary-arch
+
.PHONY: build clean binary-indep binary-arch binary install configure
+
+
diff --git a/debian/zephyr-client.config b/debian/zephyr-clients.config
index f04ef7a..26de8d3 100644
--- a/debian/zephyr-client.config
+++ b/debian/zephyr-clients.config
@@ -2,5 +2,6 @@
. /usr/share/debconf/confmodule
-db_input high zephyr-client/servers || true
+db_input high zephyr-clients/servers || true
db_go
+
diff --git a/debian/zephyr-client.files b/debian/zephyr-clients.files
index 24d35a5..24d35a5 100644
--- a/debian/zephyr-client.files
+++ b/debian/zephyr-clients.files
diff --git a/debian/zephyr-client.init b/debian/zephyr-clients.init
index 61a4fb2..293d7be 100644
--- a/debian/zephyr-client.init
+++ b/debian/zephyr-clients.init
@@ -20,9 +20,9 @@ test -f $DAEMON || exit 0
set -e
-if test -f /etc/default/zephyr-client
+if test -f /etc/default/zephyr-clients
then
- . /etc/default/zephyr-client
+ . /etc/default/zephyr-clients
fi
case "$1" in
diff --git a/debian/zephyr-client.postinst b/debian/zephyr-clients.postinst
index c49709d..d2104e3 100644
--- a/debian/zephyr-client.postinst
+++ b/debian/zephyr-clients.postinst
@@ -31,19 +31,19 @@ case "$1" in
if test -f /etc/zephyr/zephyr.conf
then
- if test ! -f /dev/default/zephyr-client
+ if test ! -f /dev/default/zephyr-clients
then
- mv /etc/zephyr/zephyr.conf /etc/default/zephyr-client
+ mv /etc/zephyr/zephyr.conf /etc/default/zephyr-clients
fi
fi
- db_get zephyr-client/servers
- if test -f /etc/default/zephyr-client
+ db_get zephyr-clients/servers
+ if test -f /etc/default/zephyr-clients
then
- grep -v ^zhm_args /etc/default/zephyr-client > $tmpfile || true
+ grep -v ^zhm_args /etc/default/zephyr-clients > $tmpfile || true
fi
echo zhm_args=\"${RET}\" >> $tmpfile
- cat $tmpfile > /etc/default/zephyr-client
+ cat $tmpfile > /etc/default/zephyr-clients
;;
abort-upgrade|abort-remove|abort-deconfigure)
diff --git a/debian/zephyr-client.prerm b/debian/zephyr-clients.prerm
index c1e3a93..5f92d7d 100644
--- a/debian/zephyr-client.prerm
+++ b/debian/zephyr-clients.prerm
@@ -17,7 +17,7 @@ set -e
case "$1" in
deconfigure|remove)
- rm /etc/default/zephyr-client || true
+ rm /etc/default/zephyr-clients || true
;;
upgrade)
# remove|upgrade|deconfigure)
diff --git a/debian/zephyr-client.templates b/debian/zephyr-clients.templates
index 70a93e2..eca3119 100644
--- a/debian/zephyr-client.templates
+++ b/debian/zephyr-clients.templates
@@ -1,4 +1,4 @@
-Template: zephyr-client/servers
+Template: zephyr-clients/servers
Type: string
Description: What are your zephyr servers?
Please type the full names of your zephyr servers, seperated by spaces.