summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Karl Ramm <kcr@1ts.org>2009-07-15 14:34:02 +0000
committerGravatar Karl Ramm <kcr@1ts.org>2009-07-15 14:34:02 +0000
commitd54bda3667ccb164fbfb37bf7b4d7aa3fea2471f (patch)
tree542a5ac3259a7991faa4747c411ff51dd7d68c08 /debian
parent827e165e5b80d999a8a30b3292f9bbb4a8c772e1 (diff)
Factor the python library stuff out of the test suite and stick
it in it's own file. And then put it in a debian package.
Diffstat (limited to 'debian')
-rw-r--r--debian/control12
-rw-r--r--debian/libzephyr-python.files1
-rwxr-xr-xdebian/rules10
3 files changed, 19 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index b7a2a30..80ce34f 100644
--- a/debian/control
+++ b/debian/control
@@ -5,11 +5,12 @@ Maintainer: Karl Ramm <kcr@debian.org>
Uploaders: Sam Hartman <hartmans@debian.org>
Build-Depends: debhelper (>= 5), libc-ares-dev, libkrb5-dev (>= 1.2.2-4), comerr-dev, ss-dev,
libreadline5-dev, libx11-dev, libxt-dev, x11proto-core-dev, libncurses5-dev,
- bison, libhesiod-dev, autotools-dev
+ bison, libhesiod-dev, autotools-dev, python (>= 2.5)
Standards-Version: 3.8.1.0
Homepage: http://zephyr.1ts.org/
Vcs-Svn: svn://zephyr.1ts.org/trunk/zephyr
Vcs-Browser: http://zephyr.1ts.org/browser/trunk/zephyr
+XS-Python-Version: 2.5
Package: libzephyr4
Section: libs
@@ -69,6 +70,15 @@ Description: The original "Instant Message" system libraries with Kerberos 4+5
users. Users can view incoming Zephyr messages as windowgrams
(transient X windows) or as text on a terminal.
+Package: libzephyr-python
+Section: python
+Architecture: any
+Depends: ${python:Depends}, libzephyr4
+Provides: ${python:Provides}
+XB-Python-Version: ${python:Verions}
+Description: Python bindings for zephyr library
+ Get at the zephyr library from python.
+
Package: zephyr-clients
Section: net
Replaces: zephyr-client
diff --git a/debian/libzephyr-python.files b/debian/libzephyr-python.files
new file mode 100644
index 0000000..5e373d8
--- /dev/null
+++ b/debian/libzephyr-python.files
@@ -0,0 +1 @@
+usr/lib/python2.5/site-packages/zephyr.py
diff --git a/debian/rules b/debian/rules
index 7a36d8d..6cf638c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,7 +11,7 @@
VARIETALS=krb5
#VARIETALS=krb krb45 krb5
-PACKAGES:=-plibzephyr4 -pzephyr-clients -pzephyr-server -plibzephyr-dev $(foreach i,$(VARIETALS),-plibzephyr4-$(i) -pzephyr-server-$(i))
+PACKAGES:=-plibzephyr4 -pzephyr-clients -pzephyr-server -plibzephyr-dev -plibzephyr-python $(foreach i,$(VARIETALS),-plibzephyr4-$(i) -pzephyr-server-$(i))
# This has to be exported to make some magic below work.
export DH_OPTIONS
@@ -118,6 +118,8 @@ install: build
for dir in $(VARIETALS); do \
cp -rp debian/tmp/etc/zephyr/acl debian/tmp-$$dir/etc/zephyr; \
done
+ mkdir -p debian/tmp/usr/lib/python2.5/site-packages
+ install -c -m 644 python/zephyr.py debian/tmp/usr/lib/python2.5/site-packages
# Build architecture-independent files here.
# Pass -i to all debhelper commands in this target to reduce clutter.
@@ -147,7 +149,7 @@ binary-arch: build install
for dir in $(VARIETALS); do \
cp debian/libzephyr4.files debian/libzephyr4-$$dir.files; \
done
- dh_movefiles -plibzephyr4 -pzephyr-clients -pzephyr-server -plibzephyr-dev
+ dh_movefiles -plibzephyr4 -pzephyr-clients -pzephyr-server -plibzephyr-dev -plibzephyr-python
for dir in $(VARIETALS); do \
dh_movefiles --sourcedir=debian/tmp-$$dir -plibzephyr4-$$dir -pzephyr-server-$$dir; \
done
@@ -158,7 +160,9 @@ binary-arch: build install
for dir in $(VARIETALS); do \
dh_installinit -pzephyr-server-$$dir --init-script=zephyrd; \
done
- dh_installchangelogs
+ dh_installchangelogs
+ dh_pycentral -plibzephyr-python
+ dh_python -plibzephyr-python
dh_strip
dh_compress
dh_fixperms