summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Karl Ramm <kcr@1ts.org>2013-01-31 08:02:34 -0500
committerGravatar Karl Ramm <kcr@1ts.org>2013-03-16 23:57:54 -0700
commit9e8331c95c94003458ec0a9f9a750bee9f25fdbd (patch)
tree3545fe8e128e6bb06a238492ad88fad32838378b /debian
parent9e361ec4b0fbf61fc743bae78ab1b6e30c4a2742 (diff)
Test the low-level code in uloc.c
Also, tweak the debian build infrastructure so that we can pass in arbitrary CFLAGS. New program test_server that links with the non-main.c parts of the server. Currently only (as above) tests the low-level bits of uloc.c.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 42e0bb3..eba0709 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,6 +22,7 @@ CONFIGURE_krb5=--with-krb5=/usr
CONFIGURE_krb45=--with-krb4=/usr --with-krb5=/usr
CONFIGURE_krb=--with-krb4=/usr
CONFIGURE_no-krb=
+CFLAGS=-g -O
CHECK=check
# see /usr/share/doc/autotools-dev/README.Debian.gz
@@ -66,7 +67,7 @@ configure-stamp:
automake -a || true # we only want this for install-sh
autoreconf
mkdir -p $(BUILD_VARIETALS)
- $(foreach VARIETY,$(BUILD_VARIETALS),(cd $(VARIETY) && CFLAGS="-g -O" ../configure $(CONFIGURE_$(VARIETY)) $(CONFIGURE_ROOT));)
+ $(foreach VARIETY,$(BUILD_VARIETALS),(cd $(VARIETY) && CFLAGS="$(CFLAGS)" ../configure $(CONFIGURE_$(VARIETY)) $(CONFIGURE_ROOT));)
touch configure-stamp
build-arch: build-stamp